El Blog de ReactOS
Blog en Español de Reactos

AVISO: Actualización obligatoria a RosBE 1.5


Pues sí. Tras los últimos cambios en el código fuente de ReactOS, a partir de este momento se requiere compilar el sistema con la versión d1.5 de nuestro ReactOS Build Environment (RosBE para los amigos). ualquier intento de compilar el sistema, según dicen tanto Daniel Reimer como Colin Finck (desarrolladores del sistema RosBE para Windows y Unix/Linux, respectivamente), fallará, debido a las nuevas herramientas actualizadas que trae consigo esta nueva versión del compilador.

Para más detalles, estos desarrolladores nos han colocado un archivo Readme.odt que podéis consultar tras la instalación del entorno.

EDITO: Se me olvidó colocar el enlace a RosBE. Disculpad el descuido. lo podéis encontrar aquí.

About these ads

7 Responses to “AVISO: Actualización obligatoria a RosBE 1.5”

  1. No puedo compilar ReactOS 0.3.11, quizás es porque he puesto fuentes externas (Ubuntu 9.10), me podríais ayudar. Gracias.

  2. Hola RakNae,
    ¿Fuentes externas?¿A que te refieres?
    Para compilar ReactOS lo único que tienes que hacer es bajarte nuestro RosBE para Linux,instalarlo,ejecutar ssvn create,(se tirará un buen rato copiandote todos los ficheros de ReactOS a tu PC) y por ultimo: makex bootcd. Debería compilártelo perfectamente.Si intentas compilar las ultimas revisiones,recuerda que tienes que instalar el ultimo RosBE como indicamos en el post.
    Dinos en que paso te falla,y que error te muestra ;)

  3. De hecho, yo acabo de actualizar a RosBE 1.5, en ambos sistemas (Windows y Linux) y he compilado perfectamente, sin ningún error…

  4. Lo he intentado compilar en Windows 7, si no incluyo las fuentes funcionaba pero si las incluyo no. El error:
    make.exe: *** No rule to make target `media\fonts\.ttf’, needed by `reactos\fonts\.ttf’. Stop.

    PD: he modificado el archivo “fonts.rbuild” e indica las fuentes, está todo “en orden” :P

  5. A partir de que version de reactos sera el cambio?, intento compilar 0.3.11 con 1.5 y me da errores, con el 1.4.5 funciona sin problemas.

  6. […] ReactOS – Actualización obligatoria a RosBE 1.5 reactos.wordpress.com/2010/02/10/aviso-actualizacion-obligat…  por ReactOS hace 2 segundos […]

  7. Hola manuel :)
    A partir de la 0.3.12 necesitarás compilarlo con la 1.5, en versiones 0.3.11 o anteriores, mejor que uses la 1.4.5 :)


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

Join 38 other followers

%d bloggers like this: